Back to overview
Maintenance

Scheduled Maintenance

May 02 at 10:00am BST  –  May 02 at 10:14am BST
Affected services
Kadence Web App
Self Service Sign Up

Resolved
May 02 at 10:14am BST

Maintenance complete. As you were 🚀

Created
May 02 at 10:00am BST

We're planning on carrying out maintenance on the Kadence cloud applications. As a result, there may be some downtime, but we'll be sure to let you know when it's complete.