Back
Maintenance

Scheduled Maintenance
Completed 22 May at 11:00am BST.
Kadence Web App
Authentication Services
Self Service Sign Up
Kadence Cloud
Updated
Maintenance complete. As you were 🚀
Posted
25 May at 11:58am BST.
Completed
Maintenance completed
Posted
22 May at 11:00am BST.

Started
We're planning on carrying out maintenance on the Kadence cloud applications. As a result, there may be some downtime, but we'll be sure to let you know when it's complete.
Posted
22 May at 10:30am BST.