Back to overview
Maintenance

Scheduled Maintenance

May 10 at 06:00am BST  –  May 10 at 06:07am BST
Affected services
Kadence Web App

Resolved
May 10 at 06:07am BST

Maintenance complete. As you were 🚀

Created
May 10 at 06:00am BST

We are currently carrying out maintenance on the Kadence cloud applications. No downtime or service degradation is anticipated for this change.